Machine tokens unable to open referenced environments when running stack previews.

Incident Report for Pulumi

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 03:52 PST

Monitoring

Rollback has deployed. We are continuing to monitor
Posted Mar 06, 2026 - 03:45 PST

Identified

We are working on a rollback that should resolve this incident. As this rollback is deploying, you may see error rates decrease for a time until the deploy is complete.
Posted Mar 06, 2026 - 03:41 PST

Update

We are continuing to investigate this issue.
Posted Mar 06, 2026 - 03:30 PST

Investigating

We are aware of issues with machine tokens having issues opening environments as part of running previews. We are currently investigating
Posted Mar 06, 2026 - 03:29 PST
This incident affected: API and Deployments.