GitHub-backed Pulumi Teams Outage
Incident Report for Pulumi
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 13:10 PST
Identified
Pulumi APIs that interact with GitHub teams are erroneously returning 404s. This includes APIs that create, manage, and validate Pulumi teams backed by GitHub teams, and SCIM integrations that provisions teams backed by GitHub.

Users may not be able to see or access stacks where access is granted via membership backed by a GitHub team. Org admins should still have access to all stacks. As a workaround, organizations that set the default stack permission to `NONE` can set the default stack permission to `WRITE` to give all members write access and bypass team membership checks.

We have identified the issue, and are in the process of preparing a patch.

https://github.blog/changelog/2022-02-22-sunset-notice-deprecated-teams-api-endpoints/
Posted Mar 01, 2022 - 08:34 PST
This incident affected: API, Console and Third Party Services (GitHub).