Elevated API error rates and latency

Incident Report for Pulumi

Resolved

The incident has been resolved.
Posted May 12, 2026 - 16:14 PDT

Monitoring

A fix has been deployed and error rates and response times have recovered. We are continuing to monitor.
Posted May 12, 2026 - 16:03 PDT

Investigating

Investigating elevated API error rates and response times, particularly with ESC endpoints
Posted May 12, 2026 - 14:05 PDT
This incident affected: API.