Degraded performance on Pulumi APIs

Incident Report for Pulumi

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 12:52 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 22, 2026 - 12:45 PDT

Monitoring

A fix has been rolled out and we are monitoring results
Posted Jun 22, 2026 - 12:44 PDT

Identified

We have identified a likely cause and are working on steps to address the issue.
Posted Jun 22, 2026 - 12:14 PDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 11:30 PDT

Investigating

We are aware of degraded performance on Pulumi APIs and are actively investigating the issue.
Posted Jun 22, 2026 - 11:06 PDT
This incident affected: API, Deployments, and Search.