GitLab Integration Issues
Incident Report for Pulumi
Resolved
This has been resolved. Users can sign in to their Pulumi account using the GitLab OAuth flow to regain permanent access to their GitLab-backed Pulumi organizations.
Posted May 18, 2022 - 10:30 PDT
Monitoring
A fix has been deployed. Users can sign in to their Pulumi account using the GitLab OAuth flow to regain permanent access to their GitLab-backed Pulumi organizations.
Posted May 18, 2022 - 04:15 PDT
Identified
We are aware that some users and organizations using GitLab-backed identity for their Pulumi organization are seeing intermittent issues with not seeing their organizations listed in the Pulumi Service UI or visible from pulumi stack ls in the CLI. This is due to changes that are rolling out to GitLab right now with https://about.gitlab.com/blog/2022/04/18/gitlab-releases-15-breaking-changes/#oauth-tokens-without-expiration. We are working on a mitigation for the Pulumi service to work with the new token expiration behaviours that are rolling out.

In the meantime, users can logout of app.pulumi.com and then login again using their GitLab OAuth login flow, to refresh the token for 2 hours. Doing so should ensure you continue to see these organizations.
Posted May 17, 2022 - 10:00 PDT
This incident affected: API and Console.